Install and initial configure OpenWRT/LEDE firmware for dual band gigabit router TP-Link Archer C2600.

Table of Contents

About TP-Link Archer C2600

TP-Link Archer C2600 - a high-performance, dual band gigabit router, that was been announced by TP-Link in May 2015.

TP-LINK Archer AC2600 has a Qualcomm IPQ8064 dual-core ARM processor, running at 1.4 GHz, with 512MB of RAM memory and 32 MB of storage space. There are two USB 3.0 and five gigabit Ethernet ports(4 LAN + 1 WAN) on board.

More information about hardware here.

There are two hardware revision: v1.0 and v1.1 for this moment(04/16/2018). The difference between these revision is not significant and OpenWRT/LEDE project supports both of them.

Install OpenWRT/LEDE firmware

TFTP should be used for initial installation of OpenWRT/LEDE firmware.

You can use this manual to install and configure TFTP server for Arch Linux OS.

Steps to install OpenWRT:

  1. Download latest stable image of OpenWRT for TP-Link Archer C2600;
  2. Copy OpenWRT image to the root directory of TFTP server and rename it to “ArcherC2600_1.0_tp_recovery.bin”;
  3. Set static IP 192.168.0.66 for TFTP server;
  4. Turn off the router and connect to PC Ethernet port directly, not through a switch;

    If you use bridge type connection on network interface, you should deactivate it too.

  5. Press and hold “Reset” button and turn on the router. Release the “Reset” button after ~15 seconds;
  6. Wait for reboot(~5 minutes). The OpenWRT image will be transferred from the TFTP server and will be installed.

The procedure for recovery the factory firmware has the same steps, but you should download factory image instead of OpenWRT/LEDE image.

The router has the default settings after flashing of OpenWRT image and rebooting.

You should reconfigure Ethernet interface for connecting to the router after flashing, activate DHCP or set static IP 192.168.1.x (1 < x < 255).

Default router settings

Parameter Value
IP 192.168.1.1
DHCP server On
WiFi 5GHz Off
WiFi 2,4GHz Off

You can connect to the router via ssh protocol and use command “firstboot” to reset setting to default.

Configure WiFi networks

UI can be used to configure WiFi networks.

Some times, WiFi settings can not be applied without any reasons - just reboot the router.

The open source utility WiFiAnalyzer for OS Android can be used for monitoring the state of WiFi networks.

More information for configure WiFi networks are presented here.

Be careful, routers for selling in USA, according to the FCC requirements, have a some hard-coded limitation for WiFi networks.

There is no a simple way to disappear this limitations for TP-Link Archer C2600.

Configure hardware switch

Hardware switch configuration:

Port Switch port
CPU eth0 0
CPU eth1 6
Internet (WAN) 5
LAN 1 4
LAN 2 3
LAN 3 2
LAN 4 1

Unlike the Asus RT-N16, the hardware switch was correctly configured by default, there is no needed any additional actions to configure hardware switch for TP-Link Archer C2600.

Default settings are correct and presented below:

/etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdcc:dda2:2909::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.0.1'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'
	option hostname 'HomeNetwork'
	option macaddr 'A7:08:A1:6F:68:FD'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0'